Missing buybox information, reviews & questions due to website changes on Amazon
Incident Report for Sellics
Resolved
All inforamtion should now be updated by now.
If you still experience any issues please let us know.

Thank you for your patience.
Posted Mar 20, 2019 - 15:33 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 20, 2019 - 11:38 UTC
Update
We see an ongoing delay for Reviews and Questions. We continue to work towards a solution.
Posted Mar 19, 2019 - 11:49 UTC
Monitoring
We identified the source (3rd party provider) and are working towards a solution. Most rankings, reviews and buy box data should be back by know. If that is not the case for you please let us know.
We are monitoring the situation closely.
Posted Mar 19, 2019 - 09:50 UTC
Identified
Buybox data as of March 16th and beyond maybe incorrect leading to increased lost buybox reports in Sellics.

Amazon made some unannounced changes on their website affecting our infrastructure to retrieve buy box data. Our team will investigate and adapt to these changes as fast as possible. Please subscribe to this incident for further updates.

Thank you for your patience in the interim.
Posted Mar 18, 2019 - 10:22 UTC
This incident affected: Buybox & Inventory.