Scheduled Maintenance MONDAY July 6th
Incident Report for Sellics
Resolved
The maintenance could be performed. Thank you for your patience.
Posted Jul 07, 2020 - 10:04 UTC
Identified
Due to a scheduled maintenance the tool will not be available on Monday, July 6th 2020, from 6 - 8 p.m. Berlin time (UTC +1).
Posted Jul 06, 2020 - 10:26 UTC
This incident affected: Tool overall.