PPC Integrations not displayed in Amazon Advertising feature
Incident Report for Sellics
Resolved
This incident has been resolved. We apologize for the caused inconveniences and thank you for your patience.
In case you're still experiencing any issues please reach out to vendorsupport@sellics.com
Posted May 27, 2020 - 12:08 UTC
Update
We are continuing to investigate this issue.
Posted May 26, 2020 - 19:12 UTC
Investigating
We are currently working on restoring access to the PPC Integrations in the Amazon Advertising.
We apologise for any inconveniences that this has caused and we will have the feature running again soon.
Posted May 26, 2020 - 19:11 UTC
This incident affected: Advertising.