Keyword research currently unavailable
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 12:01 UTC
Investigating
The keyword research feature is unavailable at the moment. We are investigating the issue and will provide a fix as soon as possible. Thank you for your patience.
Posted Mar 13, 2020 - 11:48 UTC
This incident affected: Content & SEO.