"Track Keywords" not available at the moment
Incident Report for Sellics
Resolved
This incident has been resolved. Thank you for your patience.
Posted May 11, 2020 - 10:08 UTC
Investigating
We are experiencing an issue that freezes the screen when clicking on "Track Keywords" (Content & SEO) and the page has to be reloaded. Our team is investigating the issue and we will inform you here as soon as a fix has been implemented. Thank you for your patience.
Posted May 07, 2020 - 12:38 UTC
This incident affected: Content & SEO.