Content & SEO: Keyword Research out of order
Incident Report for Sellics
Resolved
This incident has been resolved. In case you're still experiencing any issues with this feature please reach out to our support team under vendorsupport@sellics.com. Thank you for your patience.
Posted Jul 21, 2020 - 10:27 UTC
Identified
We're experiencing an issue in the Content & SEO module that affects the Keyword Research feature (under Keyword Research and Content Analysis). Our team is already working on a solution and we'll update here as soon as a fix has been implemented.
Posted Jul 21, 2020 - 09:05 UTC
This incident affected: Content & SEO.