AMS creation of campaigns currently not possible
Incident Report for Sellics
Resolved
The issue has been addressed and should now be possible again.
Thank you for your patience.
Posted Mar 04, 2019 - 10:20 UTC
Investigating
Due to an outage with Amazons API, creating campaigns in Sellics will result in an error message that reads: "Could not be saved. Please check change log".
We are working with Amazon to have this fixed as soon as possible. Since we depend on them to make the necessary changes there is no ETA yet. Please subscribe this incident to receive updates whenever they occur. Thank you for your patience
Posted Mar 01, 2019 - 10:26 UTC
This incident affected: Advertising.