Login currently not possible / Login derzeit nicht möglich
Incident Report for Sellics
Resolved
This issue did not affect the Vendor Edition. Sorry for the false alarm
Posted May 02, 2019 - 09:33 UTC
Investigating
Our account management service is experiencing issues resulting failed logins for all users. We work together with them to have this resolved with utmost urgency.

For updates about the situation you can subscribe to this incident.
Posted May 02, 2019 - 09:31 UTC
This incident affected: Tool overall.