Advertising Module: Scheduled Maintenance TUESDAY June 9th
Incident Report for Sellics
Resolved
The tool is available again. Thank you again for your patience.
Posted Jun 09, 2020 - 11:52 UTC
Identified
Due to a scheduled maintenance the Advertising Module will not be available on Tuesday, June 9th 2020, from 12 - 2 p.m. Berlin time (UTC +1).

We thank you for your understanding and patience.
Posted Jun 08, 2020 - 13:27 UTC
This incident affected: Advertising.