Missing reviews since 21.02.2020
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted Mar 06, 2020 - 10:38 UTC
Monitoring
A fix has been provided for this issue and reviews are starting to populate again within the dashboard. Backfilling of all the reviews which didn't come through over the past days will also be progressively done over the day.

Our sincere apologies for the inconvenience caused and thank you for your patience.
Posted Mar 05, 2020 - 09:57 UTC
Identified
We are experiencing issues with showing reviews since 21.02.2020 for some accounts. Our team is already working with high priority to provide a fix as soon as possible.
Posted Feb 28, 2020 - 12:56 UTC
This incident affected: Chatter.