Scheduled Maintenance SUNDAY February 9th
Incident Report for Sellics
Resolved
This incident has been resolved.
Posted Feb 10, 2020 - 08:22 UTC
Investigating
Due to scheduled maintenance the system will be inaccessible Sunday February 9th between the following hours:

Sellics Vendor Edition: 10am-11am CET (1am-2am PST)
Sellics Amazon Advertisting: 10am-4pm CET (1am-7am PST)*
*The automation service will still work as usual

Thank you for your patience in the matter and please reach out to support via the chat box or vendorsupport@sellics.com for questions or concerns.

Team Sellics
Posted Feb 05, 2020 - 16:10 UTC
This incident affected: Tool overall.